Fixing Invalid Steam User ID issue

Discussion in 'Support' started by Trickster, Nov 23, 2011.

  1. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    I'm sorry you feel this way, but the Invalid Steam User ID problem is mod-wide. You can head over the forums of most other mods, and they're all having the same issues. It's a Valve problem with SDK Base 2007.
     
  2. мrвlυeѕĸy

    мrвlυeѕĸy Member

    Messages:
    140
    Likes Received:
    12
    Trophy Points:
    0
    Steam is being disablist and calling me an invalid again....

    None of the techniques described worked and I can't be arsed to google it. Any ideas.... come one guys... I make up at least 25% of the empires community. You cant afford to lose me.
     
  3. Señor_Awesome

    Señor_Awesome Member

    Messages:
    1,511
    Likes Received:
    58
    Trophy Points:
    0
    Well isn't this just wonderful. I'm having this issue again as well. Haven't tried any fixes yet, so with any luck the ones here will work again.

    EDIT: Deleting the clientregistry.blob worked again for me, and this error is widespread yet again. Many people on servers today said they encountered the issue and fixed it by deleting clientregistry.blob
     
    Last edited: Jun 15, 2013
  4. мrвlυeѕĸy

    мrвlυeѕĸy Member

    Messages:
    140
    Likes Received:
    12
    Trophy Points:
    0
    Good call Senor... worked. Thanks
     
  5. JustGoFly

    JustGoFly Member

    Messages:
    897
    Likes Received:
    30
    Trophy Points:
    0
    This error hit myself and ScRaT tonight. I followed the instructions in this thread and the one on Steam which says: Exit Steam, blow away the whole steam folder (C:\Program Files (x86)\Steam) except Steam.exe and SteamApps, reboot.
    It reinstalls, requires you to login and re-verify - but still Empires will not work.
    Error: "Disconnect: Invalid Steam UserID Ticket"

    Other ideas here:
    https://support.steampowered.com/kb_search.php?searchwords=invalid+steam+ticket

    Another little piece of the puzzle - when it fails with this error and you exit Empires. hl2.exe sometimes remains in memory. Your FRIEND account will show you are still in Empires. So if you see guys IN empires and think this is fixed, you might want to try and join just to verify it, or check the viper/epic server status.

    I'll try again tomorrow.

    <I just tried again today and same result>

    Anyone else getting this since yesterdays Steam update, and has anyone resolved it ? Only other fix besides deleting EVERYTHING but steam.exe and SteamApps is to uninstall game and repeat the delete, then reinstall. For now I guess the other 50% of regular players (ScRaT and myself) are done for.

    This may help some, it did nothing for me:
    https://support.steampowered.com/kb_article.php?ref=4100-WEAK-4375

    I also found this interesting:
    "Two Computers, one Account Problem
    Something else that can cause this is if there is another computer that is using the same Steam account.

    When you log into a second computer with the same account that is running on the first, the Steam Ticket will invalidate on the first machine and transfer to the new Session.

    This means that the first machine will then eventually prompt for a login to establish a new SteamUserID Ticket, and if the person on that machine logs in, then the ticket will then transfer back to him.

    You need a unique Steam Account for each computer that is going to be online at the same time.
    "
     
    Last edited: Jan 17, 2014
  6. 101010

    101010 Member

    Messages:
    996
    Likes Received:
    2
    Trophy Points:
    0
    Steam's authentication servers have been hit or miss since the DDOS attack.
     
  7. [Ψ]::Solstice

    [Ψ]::Solstice Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    game don't frikkin work!!!

    sup tricks!!

    Basically the same thing Kyro said here: http://forums.empiresmod.com/showpost.php?p=428097&postcount=15

    I'll copy&paste so you don't have to click

    Hello,
    Can't connect to a server today... Invalid Steam User ID...
    I tried everything: deleted the "userdata" folder, Steam\config\config.vdf and Steam\clientregistry.blob, but nothing works, problem still here...

    I've already applied the fix for the

    MountAppFilesystem() failed:
    SteamMountAppFilesystem(17740,4294967295,0x19f5fc0 c) failed with error 5: No CS online with App 17741 Ver 0.

    error from before and it was working about two weeks ago.

    But now I'm getting the bullshit invalid Steam ID error and like Kyro said nothing works. delete clientregistry.blob, nope. Any of the other fixes I've found in these forums, nope.

    I've been launching the game from SourceSDK2007 in Tools like the homepage says but now I'm going to try downloading the gcf files and running it like normal.

    OH and whoever runs Steam should burn in a fire.

    pcz
     
  8. JustGoFly

    JustGoFly Member

    Messages:
    897
    Likes Received:
    30
    Trophy Points:
    0
    Solstice - how old is that information ?

    As of a couple days ago everyone is having this problem regardless of whether they are running Source SDK 2007 or the original without SDK workaround. Have you tried running Empires and joining the server ? Joining will fail with Invalid Ticket UserID... error.

    Has anyone been able to join a server?

    Is anyone contacting Steam about a solution?
     
  9. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
  10. 101010

    101010 Member

    Messages:
    996
    Likes Received:
    2
    Trophy Points:
    0
    There are ways around it. Not sure if posting how to on here is allowed.
    But the work around would make all server bans have to be IP bans.
     
  11. [Ψ]::Solstice

    [Ψ]::Solstice Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hi JustGoFly, it was new from yesterday.

    Yes I could join the server for about five seconds then it always kicks me back out with the invalid Steam ID error.
     
  12. BigTeef

    BigTeef Bootleg Headshot master

    Messages:
    7,036
    Likes Received:
    36
    Trophy Points:
    0
    Hey!

    Its pumpkin seed guy, how you doing?
     
  13. JustGoFly

    JustGoFly Member

    Messages:
    897
    Likes Received:
    30
    Trophy Points:
    0
    My understanding is that Valve screwed something up. Many Source 2007 SDK games are screwed. Vicki has been working on it and is desperate to find a fix, but this is out of her and the developers hands. I asked Vicki to keep first post of this thread up to date. She's looking through the forums for an answer or work around.

    http://forums.empiresmod.com/showthread.php?t=18152
     
  14. JustGoFly

    JustGoFly Member

    Messages:
    897
    Likes Received:
    30
    Trophy Points:
    0
    Vicki is my hero - she found a work around and put the time in to figure out how to fix it. VIPER IS UP !
     
  15. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    Sorry the fix didn't work
     
  16. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    Just putting this out there, I'm fairly certain that most client-side fixes will not be able to fix this problem, nor will most server-side effects. I'm theorizing that it has something to do with the new Steam streaming service causing client authentication issues on the Steam backend, but no one outside of Valve would really be able to say what the problem is.
     
  17. flasche

    flasche Member Staff Member Moderator

    Messages:
    13,299
    Likes Received:
    168
    Trophy Points:
    0
    are these gcf shenanigans related aswell?
     
  18. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    VIPER is working Players can join -I'll post how I got it to work
     

Share This Page