How to set up a dedicated server?

Discussion in 'Closed bugs' started by jensolaf, Oct 31, 2015.

Thread Status:
Not open for further replies.
  1. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    ports 27015 SV/ 27005 CL.
     
  2. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    I don't understand your answer
     
  3. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    whats the ip and port of your server
     
  4. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Public IP is 52.30.10.100.
    And port is 27015.
     
  5. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    in your server console what errors does it give? does it says its connected to steam servers? paste your errors
     
  6. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    It gives no errors.

    "Connection to Steam servers successful."
    Public IP is 52.30.10.100
    Assigned anonymous gameserver steam ID.
    VAC secure mode is activated.

    Everything responds and works.

    Can you add me on Steam?
    https://steamcommunity.com/id/jens-o/
     
  7. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    do you have -insecure in your cmd line or secure?
     
  8. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Secure.
    Was insecure at first, then changed it.
     
  9. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    change it to -insecure restart the server and see if it shows.
     
  10. flasche

    flasche Member Staff Member Moderator

    Messages:
    13,299
    Likes Received:
    168
    Trophy Points:
    0
    have you forwarded the ports?
     
  11. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    I have all posts open.
     
  12. flasche

    flasche Member Staff Member Moderator

    Messages:
    13,299
    Likes Received:
    168
    Trophy Points:
    0
    i meant your router ...
     
  13. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    It's a server.
    I dunno about it.
    My old TF2/CS:GO server worked fine there.
     
  14. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    empires server wont work right if you have secure in your cmd line.

    Are you renting the server or is it on your local computer? If you are renting from a host they need to open those same ports I posted. If its on your local pc and you are behind a router those ports needs to be open in the router not just on your personal firewall.

    type the cmd line you are using. and type the path of your Empires/empires folder so we can see if both are correct.
     
  15. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Renting.
    The previous servers worked fine there.

    Also, the cmd line;
    srcds.exe -console -game EmpTest\empires +map emp_money +maxplayers 16 -tickrate 30 -port 27015 -insecure
     
    Last edited: Nov 3, 2015
  16. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    you don't have your server ip in the command line change the cmd to look like this but put in your ip

    srcds.exe -console -game EmpTest\empires +ip yourserveriphere -port 27015 +map emp_money +maxplayers 16 -insecure
     
  17. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Engine Error: Couldn't allocate any server IP port.
     
  18. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    No put your ip in Please read what I post

    where it says this in the cmd +ip yourserveriphere edit that and put YOUR IP in
     
  19. jensolaf

    jensolaf Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    I did it.
    I put the public IP address there.
     
  20. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    srcds.exe -console -game EmpTest\empires +ip 52.30.10.100 -port 27015 +map emp_money +maxplayers 16 -insecure

    ok I thought you pasted as you quoted
     
    Last edited: Nov 3, 2015
Thread Status:
Not open for further replies.

Share This Page