Fix building placement

Discussion in 'Closed bugs' started by Xyaminou, Mar 7, 2016.

  1. Xyaminou

    Xyaminou Member

    Messages:
    1,366
    Likes Received:
    156
    Trophy Points:
    0
    I have to make a thread in here because this is a big issue that should have been fixed.
    I don't know if you're trying to fix it or what's happening.
    But it's been too long already, this is the biggest issue we have had a long time.
    What can be done can obviously be undone.
    So please, either fix it or rollback whatever was done to change it.
    If it's just a matter of losing the indication on building placement, the remove that.

    Not to mention that buildings can now be hindered by walls/ammo boxes/cameras etc... in a LARGE radius
    This was removed for a good reason, I don't know why it's back in the game, I really am sick of telling people I can't place stuff, this isn't fun for anybody.
    It should have been fixed 2 weeks ago.

    Peace.
     
  2. Thexa4

    Thexa4 Developer Staff Member Moderator

    Messages:
    304
    Likes Received:
    98
    Trophy Points:
    0
    Could you provide steps to reproduce the problem on a local server?
     
  3. Spike

    Spike Long Live The King!

    Messages:
    612
    Likes Received:
    42
    Trophy Points:
    0
    I too have noticed this while commanding it is very frustrating. it keeps saying enemies are near when there are none. Can these changes please be reverted ? because its a real game breaker for the commander. Also it prevents placing of critical refinery points. Perhaps a hotfix is needed ?
     
  4. Xyaminou

    Xyaminou Member

    Messages:
    1,366
    Likes Received:
    156
    Trophy Points:
    0
    are you serious?
    First off, half if not more of the bugs reported do not reproduce on local servers
    secondly, the "steps to reproduce" are pretty obvious in this case, play as commander, drop a building etc...
     
  5. Thexa4

    Thexa4 Developer Staff Member Moderator

    Messages:
    304
    Likes Received:
    98
    Trophy Points:
    0
    Yes, I am serious. If we are to fix the problem we first should be able to reproduce it very reliably. In the tests run before the release we didn't encounter anything like you're describing now which is why I am asking you to provide us with a set of steps to reproduce your problem so we can try things to fix the problem.

    If it's only possible to reproduce with the dedicated server that's fine as well, we can start one as well for debugging.

    Could you provide me with the steps to reach the problem you're describing and what you expected to happen instead?
     
  6. Xyaminou

    Xyaminou Member

    Messages:
    1,366
    Likes Received:
    156
    Trophy Points:
    0
    I just answered that question, and again IT IS OBVIOUS!
    Have you even played in the last 3 weeks? anyone who's played in the last 3 weeks knows about this bug.
    but since you seem to be having trouble, I'll spell it out for you.

    step #1: start windows
    step #2: start steam
    step #3: start Empires
    step #4: start a dedicated server with a map with many displacements such as emp_plunge
    step #5: join your server
    step #6: join a team
    step #7: select your class
    step #8 (optional): vote for yourself
    step #9: select a spawn point
    step #10: click "attack" to spawn
    step #11: go to your command vehicle and enter it by pressing "use"
    step #12: go into the command view by pressing F2
    step #13: click "buildings"
    step #14: click "vehicle factory"
    step #15: move your mouse around to find a place for it (you won't)
    step #16: reproduce the steps with Empires 2.6 (you will)

    enemy stuff blocking your stuff:
    step #1: start windows
    step #2: start steam
    step #3: start Empires
    step #4: start a dedicated server with an easy map
    step #5: join your server
    step #6: join a team
    step #7: select your class
    step #8 (optional): vote for yourself
    step #9: select a spawn point
    step #10: click "attack" to spawn
    step #11: go to your command vehicle and enter it by pressing "use"
    step #12: drive your vehicle close to enemy building
    step #13: go into command view by pressing F2
    step #14: click "buildings"
    step #15: click "wall"
    step #16: place a wall
    step #17: switch to the enemy team by pressing whatever the fucking button is
    step #18: go into the CV
    step #19: try placing stuff near the walls
    step #20: reproduce with 2.6

    is that clear enough or do I also need to teach use of keyboards and mouse?
     
  7. Thexa4

    Thexa4 Developer Staff Member Moderator

    Messages:
    304
    Likes Received:
    98
    Trophy Points:
    0
    Thanks for the steps.
    To summarize: the problem is that displacements cause buildings to become blocked and that buildings should be able to be built near enemy walls?

    I'll post the steps to the issue list.
     
  8. Xyaminou

    Xyaminou Member

    Messages:
    1,366
    Likes Received:
    156
    Trophy Points:
    0
    Yes...
     
  9. Sgt.Security

    Sgt.Security Member

    Messages:
    3,135
    Likes Received:
    139
    Trophy Points:
    0
    Even ammoboxes can block building placement now.

    This was fixed and somehow it's back.
     
  10. complete_

    complete_ lamer

    Messages:
    6,436
    Likes Received:
    144
    Trophy Points:
    0
    yeah, walls didnt use to block building placement as bad as it is now
     
  11. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    I've noticed on other maps some difficulty placing buildings in locations that previously were an easy drop. As if the sensitivity level to nearby objects has been dialed up a bit. Interestingly you can't place an NF VF on emp_palmbay in the upper right corner *unless you turn it slightly and intentionally collide it with the barracks. Kind of reverse there.
     
  12. Sgt.Security

    Sgt.Security Member

    Messages:
    3,135
    Likes Received:
    139
    Trophy Points:
    0
    I think it might be interesting if we drop the "sensitivity" further down and make it even easier to place buildings than before.
     
  13. A-z-K

    A-z-K Member

    Messages:
    3,241
    Likes Received:
    215
    Trophy Points:
    0
    A little bit might might help in some places where building was "iffy" like the BE barracks at the bottom of the "S-Bend".
    But going too far might make it possible to place buildings in places mappers never intended - which we could probably do without.

    Anyway - I think adding the text alert in command view is a great feature and the kind of thing we need more of.
    I guess the update has caused some trouble with building placement but once that gets sorted it is a massive step forward for making the command role less intimidating.
     
  14. Tama

    Tama Developer Staff Member Web Developer

    Messages:
    684
    Likes Received:
    74
    Trophy Points:
    0
    Found the bug; example reproduction steps on a local server:
    - start up crossroads
    - choose NF
    - open the console, put "emp_build 1 3273.120605 9105.168945 -214.816406 0" (this is near BE base, drive there first)
    - remember where that barracks is built; recycle it
    - switch to BE, place walls (or unbuilt buildings) near that position
    - switch back to NF; it is impossible to place a building near those walls with the commander interface, but if you re-run the console command above, the barracks is placed

    Hopefully I will have enough time to fix it properly this weekend.
     
    Last edited: Mar 11, 2016
    Neoony likes this.
  15. complete_

    complete_ lamer

    Messages:
    6,436
    Likes Received:
    144
    Trophy Points:
    0
    that is not the only problem. you cannot place buildings where you could previously place them in earlier versions.

    it probably has to do with whoever had touched the placement code, as you can also place turrets on buildings now. it kinda feels like you guys ignored that part of xya's post, please tell me you're working on fixing that as well.
     

Share This Page