[2.41] The damn thing keeps resetting my audio setup

Discussion in 'Bug Reports' started by D.D.D. Destroyer, Feb 23, 2013.

  1. D.D.D. Destroyer

    D.D.D. Destroyer Member Staff Member Moderator

    Messages:
    9,506
    Likes Received:
    111
    Trophy Points:
    0
    1. Start Empires
    2. Go to Options -> Audio
    3. Set speaker configuration from 2 speakers to headphones
    4. Apply, close Options window, quit Empires
    5. Restart Empires
    6. Check the settings -> it's back to 2 speakers.


    asdasf
     
  2. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    I wish I had an answer for it, I've spent god knows how many hours trying every fix I could find and none of them have worked for me.
     
  3. ViroMan

    ViroMan Black Hole (*sniff*) Bully

    Messages:
    8,381
    Likes Received:
    4
    Trophy Points:
    0
    I remember something about audio being fucked with before... do you have win7?
     
  4. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Sounds like it's not allowing some files to be client writeable. We're a little bogged down with this mountsystem error at the moment, but keep hassling me so we can look into this once we're done with that.

    Nah, I think the Win7 issue was when it kept reducing Empires sound by 80% because of the default tickbox for audio overriding if you get any mic input or whatever.
     
  5. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    To elaborate more on what I've managed to gather about this particular issue from previous searches, it has something to do with the engine checking with Windows for what the supported outputs are (Headphone, Stereo, 4.1, 5.1, 7.1) and then not allowing ones that the system says aren't supported. So, for example, because Windows doesn't think headphones support 5.1, if you try and set 5.1 in the options while using headphones it doesn't work.

    At least, this was by far the most common explanation I could find. It really could just be an issue with write-permissions, and it seems worth it to check it out, but what I said is all I've managed to find out.

    That's the one where you have to go right-click the volume icon > Playback Devices > Communications > Select "Do Nothing". Or else Windows fucks up the volume on media players and the like when you open a source game or Teamspeak.

    All in all, an entirely unrelated issue.
     
  6. Beerdude26

    Beerdude26 OnThink(){ IsDownYet(); }

    Messages:
    7,243
    Likes Received:
    13
    Trophy Points:
    0
    I think this is just a side effect of the Source engine resetting all audio several times when loading a map. Play some music with Windows Media Player and then load up a map; the Source engine will have paused the music.
     
  7. LordDz_2

    LordDz_2 Strange things happens here

    Messages:
    2,956
    Likes Received:
    93
    Trophy Points:
    0
    It does work with Spotify however, no pause whatsoever.
    *useless input +1 post*
     
  8. CyberKiller

    CyberKiller Nyooks!

    Messages:
    1,107
    Likes Received:
    8
    Trophy Points:
    0
    Oh I have had this problem for ages, a workaround is to add "snd_surround_speakers <value>" to autoexec.cfg in the Empires/empires/cfg folder. eg. "snd_surround_speakers 0" for headphones.
    Just drop this autoexec.cfg file into "\Steamapps\common\Empires\empires\cfg" and edit it with notepad to the right speaker setting from the list below.

    • Headphones = snd_surround_speakers 0
    • 2 Speakers = snd_surround_speakers 2
    • 4 Speakers = snd_surround_speakers 4
    • 5.1 = snd_surround_speakers 5
    • 7.1 = snd_surround_speakers 7
     
    Last edited: Mar 11, 2013
  9. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Anyone with decent headphones should be using 2 speakers.
     
  10. CyberKiller

    CyberKiller Nyooks!

    Messages:
    1,107
    Likes Received:
    8
    Trophy Points:
    0
    Well I force it to 7.1 to let my sound card do it's cmss-3d magic in games, I can hear what direction everything is coming from without having to use a special pair of headphones :D.
    Also with it set to 2 speakers using headphones the panning is way too extreme, setting it to headphones alters the mixing to compensate for this.
     

Share This Page