No BSPs for compiler - ever.

Discussion in 'Mapping' started by Comand'zorz' Asz, Jul 26, 2011.

  1. Comand'zorz' Asz

    Comand'zorz' Asz Member

    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    0
    I've got hammer setup for Empires - I can load entities like the barracks.
    :o :o :o :o :o :o :o :o :headshot: :headshot: :headshotmaster:
    I've tried making a simple hollow-cube with sky texture map and a prefab but neither compile - both times the compiler reports no BSP file found. Indeed, in the directories its looking, there is none, just the VMF file, so for some reason the compiler (or hammer) is not making BSP files for me, without reporting it as an error until it simply cannot find or copy them.
    Existing threads on the internets are made and commented on by total dorps. Help me empires communismty!
     
  2. Chris0132'

    Chris0132' Developer

    Messages:
    9,482
    Likes Received:
    0
    Trophy Points:
    0
    Compile log.

    Make sure you're actually running the bsp executable, if you are running the bsp executable, it will tell you why it isn't finishing in the compile log.
     
  3. complete_

    complete_ lamer

    Messages:
    6,437
    Likes Received:
    144
    Trophy Points:
    0
    i used to get this aswell. i ended up just going back to my setup for 2.31.
     
  4. Grantrithor

    Grantrithor Member

    Messages:
    9,820
    Likes Received:
    11
    Trophy Points:
    0
    Do a search for where the BSP got saved to, chances are it's saving in the wrong folder.
     
  5. mcthugg

    mcthugg Banned

    Messages:
    269
    Likes Received:
    0
    Trophy Points:
    0
    had this problem b4.No BSP was made do to errors.check your compile log.
    http://www.interlopers.net/errors/
    Also make sure security privilege isn't preventing the new BSP.
    (mainly an issue with Vista) Check directories make sure they are not read-only.
     
  6. Comand'zorz' Asz

    Comand'zorz' Asz Member

    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    0
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\vbspParallax.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\empires" "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp"

    * Could not execute the command:
    "C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\vbspParallax.exe" -game "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\empires" "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp"
    * Windows gave the error message:
    "Access is denied."

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\empires" "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp"

    Valve Software - vvis.exe (May 19 2009)
    4 threads
    reading c:\program files (x86)\steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp.bsp
    Error opening c:\program files (x86)\steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\vrad.exe"
    ** Parameters: -both -game "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\empires" "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp"

    Valve Software - vrad.exe SSE (May 19 2009)

    Valve Radiosity Simulator
    4 threads
    Could not find lights.rad in lights.rad.
    Trying VRAD BIN directory instead...
    [Reading texlights from 'C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\lights.rad']
    [1 texlights parsed from 'C:\Program Files (x86)\Steam\steamapps\[redacted]\sourcesdk\bin\source2007\bin\lights.rad']

    Loading c:\program files (x86)\steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp.bsp
    Error opening c:\program files (x86)\steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\sourcesdk_content\empires\mapsrc\emp_derp.bsp" "C:\Program Files (x86)\Steam\steamapps\[redacted]\empires\empires\maps\emp_derp.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."

    Doesn't say much.I've had less. That first one wasn't there until I tried moving my vmf file to fix the problem. No emp_derp.bsp exists on my system.

    What the crap Wait my VBSP has stopped running here.... I had it running earlier. Still no bsp then though....
     
    Last edited: Jul 27, 2011
  7. Grantrithor

    Grantrithor Member

    Messages:
    9,820
    Likes Received:
    11
    Trophy Points:
    0
    You're BSP is set to "vbspParallax.exe" I'm sure there is another file in the directory that is just called "vbsp.exe". If so, change it to that and see if that's the problem.
     
  8. Comand'zorz' Asz

    Comand'zorz' Asz Member

    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    0
    Damnit Grant In before Delete - disregard the above 2 posts - I am fixing this part on my own. 99% chance this won't fix my problem.
     
  9. Comand'zorz' Asz

    Comand'zorz' Asz Member

    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    0
    That seems to have fixed it. I thought copying over the Empires vbsp earlier today had made that error go away - maybe the debug output wasn't scrollign all the way up. Sorry about that.
     
  10. Demented

    Demented Member

    Messages:
    2,337
    Likes Received:
    0
    Trophy Points:
    0
    I always knew statistics was a fraudulent practice.
     
  11. Solokiller

    Solokiller Member

    Messages:
    4,861
    Likes Received:
    7
    Trophy Points:
    0
    If you use the default vbsp then parallax textures won't get lightmaps compiled for them properly.
     
  12. Chris0132'

    Chris0132' Developer

    Messages:
    9,482
    Likes Received:
    0
    Trophy Points:
    0
    Unless you're me in which case they work absolutely fine.
     

Share This Page