Mouse bugging (linux)

Discussion in 'Bug Reports' started by Vdragon, Jun 9, 2017.

  1. Vdragon

    Vdragon Member

    Messages:
    130
    Likes Received:
    6
    Trophy Points:
    0
    Hi,

    Now whenever i try shooting, one time out of 5 it will not work and get stuck on not shooting for 5 or 6 seconds.
    Also sometimes it jerks out all over.
    This is only happening in empires, and it wasn't doing that before.
    Also the key settings are still broken on linux.
     
  2. D.D.D. Destroyer

    D.D.D. Destroyer Member Staff Member Moderator

    Messages:
    9,294
    Likes Received:
    66
    Trophy Points:
    0
    Just to clarify. When did it start happening? Was it fine on this version?
     
  3. Vdragon

    Vdragon Member

    Messages:
    130
    Likes Received:
    6
    Trophy Points:
    0
    Yea, it was fine.
    Tbh I had my head in my ass while writing this so I'm going to investigate a little bit as this may have been caused by a change in my system.

    Ok just tried it still is doing it.
     
    Last edited: Jun 15, 2017
  4. Vdragon

    Vdragon Member

    Messages:
    130
    Likes Received:
    6
    Trophy Points:
    0
    Alright, update for this:
    It is also occuring in TF2 (although somehow it isn't as recurrent and is less invasive) so this is not empires specific. However it is a source engine bug related to alt-tabbing out of the game.
    I have found that in tf2, opening and closing the echap menu multiple time upon getting back in the game solved the problem, I haven't tried that workaround in Empires yet.

    Edit: After trying playing insurgency, I found that the echap and back trick does not work in that game.
     
    Last edited: Jun 28, 2017
  5. Neoony

    Neoony Member

    Messages:
    1,313
    Likes Received:
    85
    Trophy Points:
    0
    Are you in fullscreen?

    Maybe you wanna try windowed borderless?
    Or maybe alt-enter and again might help you to workaround (if that works in linux)
     
  6. Vdragon

    Vdragon Member

    Messages:
    130
    Likes Received:
    6
    Trophy Points:
    0
    I already tried, it appears to be a bit less recurrent in borderless window mode.
    i'm going to try the alt-enter thing.
     
  7. Neoony

    Neoony Member

    Messages:
    1,313
    Likes Received:
    85
    Trophy Points:
    0
    Also just random thoughts.

    Check your temps?
    As it might almost seem like something like alt tabbing (or maybe even the esc menu), might cool it down to stop it from happening for some time.

    ...does it later come back after you somehow work around it?
    or Iam just not sure on the consistency of it happening.
    Happens all the time...or just sometimes suddenly starts happening?

    Also only mouse or also visual tearing?
    And how about keyboard?

    EDIT: Also try disabling RAW input

    EDIT2: Any chance you got a touchpad too?

    EDIT3: some searching might suggest that something like this might not only be a source engine under linux thing...but a linux thing generally, but only happens in some "apps"
     
    Last edited: Jun 30, 2017
  8. Misfire

    Misfire Member

    Messages:
    244
    Likes Received:
    21
    Trophy Points:
    0
    I had a similar problem using a wireless mouse on linux. I tested with a usb wired mouse and that worked fine.
    I bought a different wireless mouse and it's been working well. It didn't not like the first wireless mouse for some reason.
     
  9. Vdragon

    Vdragon Member

    Messages:
    130
    Likes Received:
    6
    Trophy Points:
    0
    Temps are fine.
    Once workarounded it doesn't come back later on tf2, but apparently the workaround only work in tf2.
    It happens all the time.
    Just mouse tearing.
    Keyboard is fine.
    It only happen source in stuffs for me.
    Sorry i haven't been able to test it further I rarely play video games those days.

    It's a wired mouse that works fine otherwise.
     

Share This Page