Misfire Crash Dump 3_7_2016

Discussion in 'Closed bugs' started by Misfire, Mar 17, 2016.

  1. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    I've barely played the last couple of weeks so I didn't realize I had caught one so far back. I hope there's something helpful included. Unfortunately its 165mb even after it's zipped so I can't upload it. (Too big error). Try this dropbox address instead....

    https://www.dropbox.com/s/akpfznkox3bsa76/EmpiresCrashDump_Misfire_3_7_2016.zip?dl=0


    WARNING - DebugDiag was not able to locate debug symbols for c:\program files (x86)\Steam\steamapps\common\Empires\bin\serverbrowser.dll, so the information below may be incomplete.

    In hl2__PID__5944__Date__03_07_2016__Time_11_35_10PM__217__Second_Chance_Exception_C0000005.dmp the Module c:\program files (x86)\Steam\steamapps\common\Empires\bin\serverbrowser.dll has caused an access violation exception (0xC0000005) when trying to execute instructions from a non-executable address at memory location 0x114e07e0 on thread 0
     
  2. Lazybum

    Lazybum :D Staff Member Moderator

    Messages:
    4,823
    Likes Received:
    190
    Trophy Points:
    0
    User name is Tech? I'm just kinda surprised at the random hyperlink on that last 0.
     
  3. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    "Tech" simply the local windows account running most of the user processes. I have more than one account on this system.
    Another thought I had after posting... I'm not positive if this was captured from a client session or from running the dedicated server. I'll have to look at it more closely and keep keep better tabs on time stamps and server run times.
     
  4. Tama

    Tama Developer Staff Member Web Developer

    Messages:
    684
    Likes Received:
    74
    Trophy Points:
    0
    W00t! first crash log!

    It's in the client code, but unfortunately entirely within the source engine, for which I can only view a disassembly which isn't very enlightening. Probably won't be able to fix this crash but you never know.
     
  5. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    At least I don't feel bad now about having you mistakenly chase a dedicated server dump. Given past results, I should able to grab one or two crashes a week with enough game play.
     
  6. Tama

    Tama Developer Staff Member Web Developer

    Messages:
    684
    Likes Received:
    74
    Trophy Points:
    0
    K; could you open up DebugDiag Collection, Edit rule and set it to Mini Userdump instead of Full Userdump though? Minidumps are waaaay smaller and seem to contain everything I need. If Edit rule is grayed out, you will need to delete the rule and make a new one, following all the steps in the stickied thread.
     
  7. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    Sure, thought that's how I had it set. I'll double check and make a new rule if necessary.


    Update:
    I show minidump as my current config. Possible it was not at the time of this dump. We'll see what the next one brings.
     
    Last edited: Mar 18, 2016
  8. Misfire

    Misfire Always Lost

    Messages:
    309
    Likes Received:
    44
    Trophy Points:
    0
    Had a crash this eve with debug running but no dump was created. Anyone else have that happen? I spawned a BE medium tank with two standard missles (same slot), DU bullets and no canon. As soon as I landed in the cockpit view I was immediately thrown back to my desktop, hl2.exe gone. This is similar to crashes I've had before when on NF. It seems to pick on me most with Med tanks. I don't recall, light tanks, heavies, or jeeps doing this. Maybe one APC. I'm going to start paying close attention to the loadouts I have at vehicle spawn time.
     
  9. Tama

    Tama Developer Staff Member Web Developer

    Messages:
    684
    Likes Received:
    74
    Trophy Points:
    0
    I've found and fixed that one, Misfire. It happens whenever you click immediately after spawning any tank. So if you clicking impatiently through the Next buttons, you will likely crash.
    Edit; correction, not any tank - it happens when you fire a vehicle MG too fast after spawning the tank.

    If you open up DebugDiag Collection, does it say the rule is active?
     
    Last edited: Mar 19, 2016

Share This Page