I found a trick to avoid alot of your launch problems

Discussion in 'Support' started by Karhell, Nov 23, 2013.

  1. Karhell

    Karhell Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    During 2 days i had all the problems alot speak about here. Black/white screen, engine error: Unable to load client database / Mountappfilesystem() failed
    Miss some vtf files, some manifest,...

    And i finaly find something to launch the game.

    Go into your Tools list on Steam. Right click Source SDK Base 2007 and add in launch options: -game ..\empires\empires (if your Empires folder is in the same parent folder than Source SDK Base 2007, otherwise write the full path to empires\empires folder)
    Then launch Source SDK Base 2007.

    Enjoy ;)

    EDIT: If you want to use full path and have a space in the path to Empires, don't forget to use quote (" ") Ex: -game "C:\Program Files (x86)\Steam\SteamApps\#folder where is Empires#\Empires\Empires"
     
    Last edited: Dec 18, 2013
  2. Xellos

    Xellos Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Your fix is bad and you should feel bad! (Atleast for me.)

    For some reason neither source SDK base (Says that gameinfo.txt dosent exist)
    nor the game whit the exact same error. :\
     
  3. Karhell

    Karhell Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Error you get happen when you point to an invalid folder.

    How ..\empires\empires is write only work if Empires folder is in the same parent folder than SDK otherwise the easier is to write the full path to empires\empires\ folder

    Exemple: -game "C:\Program Files (x86)\Steam\SteamApps\#folder where is Empires#\Empires\Empires"
     
    Last edited: Dec 18, 2013
  4. madboi9o2

    madboi9o2 Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    It works; if you have the steampipe update, SDK 2007 should be in the Common, along with Empires. If it is, do
    Code:
    -game ../empires/empires
    and just Play!
     
    Last edited: Nov 24, 2013
  5. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Keep things like this coming. We're literally putting all our resources into trying to fix the launch problems at the moment, so every little "trick" that allows the game to boot up can give us more information as to why the whole thing happens in the first place.
     
  6. Karhell

    Karhell Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I'm looking everywhere if i can find how launch under Steam can be different than outside. Perhaps the Steam data base dll Constants only use when launch from Steam (private). I'm still looking.
     
  7. chrono

    chrono Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0
    tools->sdk 2007 -> right click -> properties - > set launch options:

    i have tried :
    1)-game D:\program files\Steam\SteamApps\common
    2)-game D:\program files\Steam\SteamApps\common\empires
    3)-game D:\program files\Steam\SteamApps\common\empires\empires

    empires mod does not initiate

    all my steam sdk and empires are updated and in common folder.


    the error i receive is the following:
    "
    setup file 'gameinfo.txt' doesn't exsist in subdirectory 'd:\program'.
    check your -game parameter or VCONFIG setting.
    "
     
  8. 101010

    101010 Member

    Messages:
    996
    Likes Received:
    2
    Trophy Points:
    0
    Don't forget you may need to remove your environment variables.
    They could still point to steamapps/username.
    Now they should be steamapps/common
    Any environment variable you set will take priority

    Be very careful when changing or deleting environment variables.
    If you don't know what you are doing leave them alone.
     
    Last edited: Nov 30, 2013
  9. chrono

    chrono Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0
    .

    i dont have any username folder

    all in common folder. "common"
     
  10. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    Use the launch option <-game ../empires/empires> instead of a direct path to the Empires install. Environment variables won't make a difference here, you're not using any of them.

    Or if you insist on using a direct path, use <-game "D:\program files\Steam\SteamApps\common\empires\empires"> You need to have a quotes in there because Windows interprets the space in "program files" as the end of the path.
     
  11. chrono

    chrono Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0

    i have changed the command line according to your last post.
    empires launches now and seems to work regularly now. thanks.
    i mistaken the two dots after the "-game" as a shorcut of the poster rather than a command.


    oh ok, now i understand much better why it said "d:\program ". thanks for responding and for the information.

    the only problem now is that servers are empty :)

    ... :\
     
    Last edited: Nov 30, 2013
  12. ViroMan

    ViroMan Black Hole (*sniff*) Bully

    Messages:
    8,381
    Likes Received:
    4
    Trophy Points:
    0
    because no one else can get it started. :(
     
  13. chrono

    chrono Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0
    you mean even with sdk2007? following all steps?

    just to be clear, the steps i took that made my empires client currently playable are these:

    * i have uninstalled steam.
    * i have reinstalled steam.
    * after re-installing steam, i installed empires mod, which also required the installation of sdk 2007.
    both of them where sucessfuly installed.
    * i validate them both. sucessfully.
    * tried to play empires mod --- error still exsist. cant run.
    * i installed the fix that was provided in the first post of this thread. i extracted the zip file following the instructions that was given - 3 files to be extracted to the steam\steammaps\.
    as of now, inside my steam\steammapps directory there are three files in a "*.gfc" format.

    * inside steam, pressed "library" button, then tools -> sdk 2007 -> right-click sdk 2007 -> properties - > set launch options
    in the command line i entered EXACTLY the following:
    -game ../empires/empires

    * pressed on sdk2007 to run it - empires is running
     
    Last edited: Dec 1, 2013
  14. ViroMan

    ViroMan Black Hole (*sniff*) Bully

    Messages:
    8,381
    Likes Received:
    4
    Trophy Points:
    0
    That is half of the point. Who will want to go through all that shit to try a new game? Those who already have the game installed can see from the server listing that no one is playing. To them it is like... why bother?

    I am normally not pessimistic about empires, "liveliness" but, even I must admit that with the number of times I check a day, empires servers are empty most of the time. Bad signs are bad.
     
    Last edited by a moderator: Dec 1, 2013
  15. chrono

    chrono Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0
    i did not say otherwise.

    ...besides the current issue that exsist,
    the TRUE problem of empires publicity is lack of proper presentation of footage and\or trailer. empires is empty(22 players in one server at best) a long time
     
  16. 101010

    101010 Member

    Messages:
    996
    Likes Received:
    2
    Trophy Points:
    0
    Not really.....People know about Empires.
    Since the steam release it has just been bad luck.
    The updates since being on steam have been broken. (People not being able to get in game) On top of that the scripts are still broken and unbalanced.
    The number 1 reason for Empires being dead is...............BAD ADMINS and a shitty map rotation.
    Talking about Viper as no one plays on Epic.
     
  17. D.D.D. Destroyer

    D.D.D. Destroyer Member Staff Member Moderator

    Messages:
    9,507
    Likes Received:
    111
    Trophy Points:
    0
    VIPER admins definitely spoil some rounds.
     
  18. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Barring Fission (which did get fixed a few months ago btw), I'm not sure what you mean here.
     
  19. 101010

    101010 Member

    Messages:
    996
    Likes Received:
    2
    Trophy Points:
    0
    Every game is HE cannon, Bio ml, 3phase. If you are a com and don't research them you lose. Other then fission the other script issues are minor. Things people have already talked about and you said are going to be fixed in the next update. (buffs + nerfs) Things that could have been worked out if more people showed up for testing the scripts b4 the last update.
     
  20. Lazybum

    Lazybum :D Staff Member Moderator

    Messages:
    4,823
    Likes Received:
    190
    Trophy Points:
    0
    That isn't always true, a lot of commanders like other research paths. Things like asorbant, ugl , and either gas turbine or bio deisel. Electrical with reactive is also pretty popular. I do agree that too many people get HE, I mean if you are gonna get most of your stuff in bio or electrical it would be pretty nice to get ranged cannon.

    It is just a problem of Ugl being so easy and cheap to use, even in late game. But that has been discussed to death already.
     

Share This Page