Fix For MountAppFilesystem() failed

Discussion in 'Support' started by vipervicki, Feb 21, 2013.

  1. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
  2. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Does this work 100% of the time? I ask because, I thought we'd fixed the problem but I got my brother to test the beta version. It wasn't fixed for him. If this seriously fixes it 100% of the time then we can finally put this problem to bed.
     
  3. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    Not sure I don't get feedback from those who tried it except they tell me it works right after installing the gcfs, after that I don't know.
     
  4. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    I gave someone the gcf files because he got the error MountAppFilesystem() failed. and empires worked fine after that, but now when he gets an HL2 DM update, empires won't load. Empires works fine since he added the gcf files until HL2 DM updates..he has to run source sdk 2007 after an HL2 DM update and then empires works fine again..anyone else have such an issue? Can any Dev explain this?
     
    Last edited: Feb 22, 2013
  5. Silk

    Silk Mapper

    Messages:
    3,145
    Likes Received:
    34
    Trophy Points:
    0
    With these files i can start up empires at least

    Not yet sure about the beta version or the sourceDK

    Edit: can't yet say anything about updates breaking things
    Edit2: SDK is working as well now
     
    Last edited: Feb 22, 2013
  6. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    so far everyone I know that has added the 3 gcf's can load empires.
     
  7. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Ok, I'll assume this is a fix and find out why it's required etc. GCFs should no longer be required so something at the Steam interface is clearly fucked up. Thanks for the find here, it really is a lifesaver for us.
     
  8. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    glad I could help.
     
  9. [lodw]keef

    [lodw]keef Hobbit

    Messages:
    1,335
    Likes Received:
    3
    Trophy Points:
    0
    this didnt work for keef :-/

    EDIT: I already had the files too, but I replaced in-case something was corrupted or what not, just FYI

    EDIT2: well just made made my error go again, not actually same error as this post, ignore.
    [​IMG]
     
    Last edited: Feb 23, 2013
  10. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    Have you tried turning it on and off again?
     
  11. [lodw]keef

    [lodw]keef Hobbit

    Messages:
    1,335
    Likes Received:
    3
    Trophy Points:
    0
    steam? ya thats the only way to get rid of it, it seems to think other shit is running even if you kill all the processes, you cant even shut steam down without ending it's process with taskmanager. Literally going between anything requires you to kill steam and restart it, not even full applications. If I compile a map, I have to compile vbsp, restart steam, compile vvis, restart steam, compile ldr vrad, restart steam, compile hdr vrad, restart steam, load empires.

    highly annoying.
     
  12. Tuxu

    Tuxu Member

    Messages:
    308
    Likes Received:
    1
    Trophy Points:
    0
    it didn't work for me and it had cost me the PUG this evening(230213). I'm going to play soliter or minesweeper or whatever not requiring steam...

    Srsly now, any clue why this is happening? maybe its a .NET or other dev environment issue? I mean that the end client env and the server\dev env may differ from one eachother.

    I wouldn't want to install dev tools for programing, 3D dev tools are enough for me. :rolleyes:

    my error was saying this:

    MountAppFilesystem() failed:
    SteamMountAllFilesystem(17740,4294967295,0x19b3fb7c) failed with error 5: NoCS online with App 17741 ver 0

    one time it reads 17740 and on the other it's 17741!? is that suppose be like that?
     
    Last edited: Feb 23, 2013
  13. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    can you paste the path of the files you extracted? you need to take the files out of the folder and put the 3 individual files in steam/steamapps

    I mention this because someone put the whole folder with the 3 files in steam/steamapps which won't fix the problem
     
  14. vipervicki

    vipervicki Member

    Messages:
    2,610
    Likes Received:
    130
    Trophy Points:
    0
    thats not the error for this fix
     
  15. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Valve have emailed us saying they've tried fixing it at their end. No-one seems to want to help me to test this, despite my 1000000 pms I'm spamming over Steam at people.
     
  16. Candles

    Candles CAPTAIN CANDLES, DUN DUN DUN, DUN DUN DUN DUN.

    Messages:
    4,251
    Likes Received:
    10
    Trophy Points:
    0
    What do you need tested, exactly?
     
  17. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Could you start Empires before or did you get the mount app error? If no, done. If yes, continue.

    Have you used the temporary fix Vicki provided? If yes, done. If no, continue.

    Can you start the game now (when you could NOT previously and you have NOT used Vicki's fix to rectify this)?
     
  18. CyberKiller

    CyberKiller Nyooks!

    Messages:
    1,107
    Likes Received:
    8
    Trophy Points:
    0
    Ok I just tested this by deleting the gcf files then launching the game (deleting the gcf files before you 'fixed' it would cause the same problem as in the OP), it is now possible to start the game without manually adding the gcf files but now it just creates the empty gcf files again instead.
    Therefore we are back to square one with the same problem we had before with it creating blank unused gcf files and wasting 2GB of hdd space.

    EDIT: I had a look at the build script on the server (didnt touch anything) and I found something interesting in one of the help files:
    To sum it up it looks like you should be able to edit the steam database for empires.
    There appears to be an option for making depots optional and at the very least changing the min/max sizes of the gcf files so that they don't take up so much disk space.........

    Looking at the database file in notepad it does appear to set which gcf files are required by empires (including the 3 redundant empires ones) and even has Empires_content set to a minimum size of 2939MB.
    I dare say editing this file directly would have no effect as it probably needs to be done using content tool program like the help file shows so that the changes get reflected on valves end.

    Anyway I didn't change anything, because it's not my stuff or my problem and I don't know enough about this anyway.
     
    Last edited: Feb 27, 2013
  19. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    Well, the point is that people can actually boot the game now. The wasted space is a problem but we can at least patch for now, then try messing with the build-script for future beta builds after this patch. I can put up with people wasting 2GB of space for one patch. If that is the fix then that's awesome, I just hope it's that simple.
     
  20. CyberKiller

    CyberKiller Nyooks!

    Messages:
    1,107
    Likes Received:
    8
    Trophy Points:
    0
    Well at the very least it looks like you can alter the initial size of the gcf files to stop them taking up 2gb of space (I have loads of space but things like that annoy me anyway).
     

Share This Page