Emp on Steam on Wine on Linux Debian6

Discussion in 'Support' started by bitchslap, Dec 5, 2011.

  1. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    Oi,

    Tis I, long time no see and to those I don't know yet, double oi.

    Looking for some assistance getting my empires running on a new setup.

    Main issue besides the occasional crash is the seeming appearance of a 'missing layer...overlay comes to mind, but have yet to come across any cvar that jogs my memory of that, and it specifically affects the following that i've been able to notice.

    hud - missing pieces, 'flicker-intermittent'
    spawn selection map
    minimap
    names over ppl

    a lot of 'minor' stuff, yet relatively essential to play fully.
    if anyone has had any specific success with things like this please respond as I don't wish to spend days trying every option under the sun.

    Specs:
    -------------------
    Debian 6.0.3
    Wine latest 1.3.34
    Nvidia GT 220 - Nvidia drivers 3.3.0 - 290.10 (latest) opengl works well in linux
    3gb RAM
    Intel Dual Core 2.7gHZ

    Be happy to answer any questions, would really like my empires to work RIGHT.

    Thx!
     
    Last edited: Dec 6, 2011
  2. w00kie

    w00kie Mustachioed Mexican

    Messages:
    3,863
    Likes Received:
    13
    Trophy Points:
    0
    I wonder if vmware -> XP would be of any help, don't know if they support proper 3d acceleration. But I would try that if I where you. (might still be a horrible idea though)
     
  3. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
  4. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    koo, ty will try him.
     
  5. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    trickster - ty, will try him


    do you even have a clue about using linux for empires or do you just like to post?
    I'll look into in, but I've already got emp running on Wine, Dx9 and fps is generally Good, it's just the minimap, names over ppl and small really useful stuff that I need to 'fix'.

    Sooooooooo, I'm hoping that some 'emplinux' knowledgeable guy will reply with some assistance.

    (like I needed to clarify....seriously:rolleyes: )

    wookie weren't you in MAD at one point?? or is it just the veterancy I perceive?
     
  6. Marshall Mash

    Marshall Mash 3D Artist

    Messages:
    590
    Likes Received:
    0
    Trophy Points:
    0
    Might want to check with eth0 as well, he seems to know a lot about linux in general.
     
  7. w00kie

    w00kie Mustachioed Mexican

    Messages:
    3,863
    Likes Received:
    13
    Trophy Points:
    0
    I was in BFAS and BSID back in the day, now I'm all Entropy. And yes, I like to answer support questions without providing any help but bad suggestions. :|ove:
     
  8. siro

    siro Member

    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    0
    fix

    Hi,
    this is bug http://bugs.winehq.org/show_bug.cgi?id=20053.
    It's vendor specific, you have a Nvidia graphics card, thats supports Pixelshader 3.0 or better.

    You can give a try to vmware -> XP, but it's not opensource.

    To fix this bug, compile wine from source.

    Edit ./dlls/wined3d/directx.c
    At line 4829 add:
    if (caps->PixelShaderVersion >= 3)
    caps->PixelShaderVersion = 2;

    This will tell any game that your graphic card does only support Pixelshader 2.0. Ingame it will report "Found DirectX 9.0 Hardware".

    Or get a new graphic card (NOT nvidia).

    PS wine1.3.34 seems to be stable.

    siro
     
  9. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    zomg, thank you so very much for ANY lead. I will pursue this tomorrow evening and report if successful.

    The link was also very helpful. And so I'm hopeful something will work. :)

    Woot!
     
  10. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    RAWR, ty Siro i got a 98% working copy now!!! just screwed up something with audio in the compile so wine is not detecting any driver currently, but I got the big issue fixed which was that horrible little GFX bug, wow its nice to see my minimap and spawn points and crosshair....

    sigh...SO NICE... :)
     
  11. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    If anyone is interested, figured I'd post my successes here and offer any help I can to others who might seek to do the same with emp on wine.

    Latest:
    ---------
    -recompiled with proper audio dev files = audio working
    -nvid bug (stated in siro's post) incorporated pre-compile has fixed gfx overlay issues
    -game running great, fps as low as 18-20 with major action

    error: system is crashing (vid card shutsdown) due to card overheating to 110 Celsius after approx 5-10 mins

    next solution : implement bumgravy's autoexec.cfg settings




    SPECS
    --------
    H/W
    Intel Dual-core E5400 2.7 Ghz
    3GB Ram
    Geforce GT220 1GB (Version 3.3 - 290.10 nvid drivers)

    S/W
    OS Debian 6.0.3 (gnome 3)(kernel 2.6.32-5-686)
    Wine 1.3.34 (compiled locally)
    PlayonLinux (latest)
     
  12. w00kie

    w00kie Mustachioed Mexican

    Messages:
    3,863
    Likes Received:
    13
    Trophy Points:
    0
    Do you get an Error message about the card overheating or is it really that hot while you are crashing?
     
  13. Trickster

    Trickster Retired Developer

    Messages:
    16,576
    Likes Received:
    46
    Trophy Points:
    0
    It shouldn't be overheating, that points to a bad overclock or poor thermal paste application.
     
  14. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    ya i've got a few things to check and the physical reality of the card is one.

    paste
    dust
    airflow

    but i get this funny feeling its driver related or configuration of the setup. if all looks fine one the inside, i'll be regressing drivers me thinks.

    it's been a few years since i've really been inside the machine so lord knows...
     
  15. w00kie

    w00kie Mustachioed Mexican

    Messages:
    3,863
    Likes Received:
    13
    Trophy Points:
    0
    The only thing I can imagine why a low-end card like that would overheat is driversided miss-use. Like when the driver makes heavy use of the same special part of the GPU over and over, while that part is not designed for that. But I'm not a professional, I just remember overheating issues with Battlefield Bad Company 2 that where caused by something like that.
     
  16. FN198

    FN198 Member

    Messages:
    2,434
    Likes Received:
    0
    Trophy Points:
    0
    posting because i played empires on my arch linux x120e with proprietary catalyst drivers.

    btw, it was horrible. like 10 fps and sprites were frozen oh g... essentially it was terrible.
     
  17. siro

    siro Member

    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    to play on linux you need a powerful graphic card and in my opinion ATI graphic drivers just fail on linux. Play with low settings and low texture sizes. I don't know why this is a problem, but I get low performance with texture sizes equal or greater medium...
    MSAA is working in newer releases, but it's still beta.
    Conclusion:
    install windows if you want to be a pro gamer :)
     
  18. ViroMan

    ViroMan Black Hole (*sniff*) Bully

    Messages:
    8,381
    Likes Received:
    4
    Trophy Points:
    0
    I hate to say it but, that statement seems valid.
     
  19. bitchslap

    bitchslap Member

    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    0
    i'm getting very good fps with my rig. Totally playable. Of course i m sure i could crank the quality settings on winxp if i wanted to and get even better fps than i am now.

    Regardless, admins when i get it 100% i will repost and would ask that you cleanup the thread and sticky it, please and thank you.

    That should be in about 2 weeks after i move and get new internet as i'm pretty sure i'm crash free now.

    Cheers, B
     
  20. flasche

    flasche Member Staff Member Moderator

    Messages:
    13,299
    Likes Received:
    168
    Trophy Points:
    0
    why in the world would you want to use xp?
     

Share This Page