crashing at the end of the game

Discussion in 'Bug Reports' started by Xyaminou, May 12, 2017.

  1. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    it's the 3rd time I crashed at the end of a game since 2.13 something's fucked...
     
  2. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    Which map?
     
  3. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    3 different maps, beachfront, vehicletraining, can't remember the other one.
     
  4. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    about 10 people just crashed at the end of emp_isle, may or may not be related, also I just noticed this is in support and not in bug report, can someone move it?
     
  5. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    Do any of them have detail objects? i don't think beachfront does... but i'm not sure about the other two...
     
  6. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    I don't know what that is.
     
  7. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    Small sprites/models that emit from materials. Grass sprites and such like. There is an issue with the detail objects, and they are causing crashes currently. i've fixed it for the next patch (i hope...)

    More specifically, a detail object is a small detail that fades-out at a shorter distance to other world objects. Grass, pebbles and some bushes come under this category.
     
    Last edited: May 14, 2017
  8. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    and I crashed AGAIN at the game fucking end, on palmbay, was the only one crashing it seems.

    Can we fucking rollback yet or should I just quit Empires?
     
  9. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    If you were the only one crashing? Then it's doesn't appear to be a bug with everyone's empires...

    I'm going to sound like tech-support here... sorry.

    Do you have any modifications to the client side game data at all?
    Furthermore, any server plugins that affect your client at the end of the game may also be causing client crashes.

    We've recently added javascript enabled HUD elements... So if you've got a custom UI setup or anything, that might be causing it.



    Finally... Have you tried verifying the game cache? Incase one of your files got corrupted somehow. This will overwrite any custom changes you may have made though...
     
    Last edited: May 14, 2017
  10. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    First of all I'm not sure I was the only one crashing, second of all my other post clearly showed a case where lots of people crashed.

    I don't have any modification whatsoever and verifying game cache never ever solved anything.

    [​IMG]
     
    Last edited: May 14, 2017
  11. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    I assume you've run a verify game cache then? And the issue still persists? Mine often finds 10 or so files that it can re-download....
    What do you mean by game end? You mean when the "game over" happens? When the map changes?
    Also, does this happen on every server?

    Unless more people report this behaviour (i've never experienced it), i will assume it is a bug with your install only.
    If no custom content is present, and your sure its not a bad command sent by the server... Try a fresh re-install?

    EDIT: Can you post the minidumps that are generated when this happens?

    EDIT 2: Seems others are experiencing similar issues... I don't have time to look into crashdumps, but if you could post them, then some other devs might be able to?
     
    Last edited: May 14, 2017
  12. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    At the exact moment the CV dies.

    I don't know if it happens on every server, does on mine and memehouse for sure.

    I don't know what minidumps, if it's the bug report stuff that I did months ago that lags the game and generate hundreds of files, no thanks.
     
  13. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    In your base empires folder, there should be a collection of minidumps (.mdmp files), every time the game crashes, it generates one.

    If you could post the one at the relevant time to your crash, we might be able to take a look at it.
     
  14. Xyaminou

    Xyaminou Member

    Messages:
    1,367
    Likes Received:
    156
    Trophy Points:
    0
    nope, oh you mean Empires install folder, not the base one.

    Here is ALL of them, the last 10 or so must be it.
     
  15. VulcanStorm

    VulcanStorm Developer Staff Member Moderator

    Messages:
    552
    Likes Received:
    64
    Trophy Points:
    0
    From a recent one at random, its an invalid memory access again (sigh), but not null... You say it's related to the commander dying? I'll take a look, can't guarantee anything though....
     

Share This Page