Command "Place Structure" state causes visual bug

Discussion in 'Bug Reports' started by Cokemonkey11, Jun 28, 2015.

  1. Cokemonkey11

    Cokemonkey11 Member

    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    0
    If you enter commander mode and begin to place a building, but exit the command vehicle without dropping or canceling the structure, then open engineer menu to place a structure, the commander 'ghost' object will cause a visual bug.

    Steps to reproduce:

    * Spawn as Engineer

    * Enter command vehicle

    * Select the wall tool and mouse over the map surface

    * Exit the command vehicle without canceling the structure placement, nor placing the structure

    * Switch to engineer too

    * Open engineer menu and select a structure - for example supplies

    * Observe that, in addition to supplies, a "Ghost Wall" placement indicator will appear.
     
  2. Metruption

    Metruption Member

    Messages:
    804
    Likes Received:
    4
    Trophy Points:
    0
    It's possible to have a ghost camera+wall+turret as engineer
     
  3. Cokemonkey11

    Cokemonkey11 Member

    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    0
    I'm not sure if you're trying to say the ghost placement indicator is a feature of engineer tool (it is), in which case you haven't understood me.

    The bug I'm referring to here is that, rather than have one "ghost" indicator for the structure you select, the commander's ghost indicator state bleeds into the engineer's build state, and two ghost indicators appear at once.
     
  4. D.D.D. Destroyer

    D.D.D. Destroyer Member Staff Member Moderator

    Messages:
    9,506
    Likes Received:
    111
    Trophy Points:
    0
    I get what you're saying, but I never got all three to show.
     
  5. flasche

    flasche Member Staff Member Moderator

    Messages:
    13,299
    Likes Received:
    168
    Trophy Points:
    0
    lucky you ^^
     
  6. Z100000M

    Z100000M Vithered Weteran

    Messages:
    9,120
    Likes Received:
    70
    Trophy Points:
    0
    I even had opposing sides turrets show up there..
     
  7. Metruption

    Metruption Member

    Messages:
    804
    Likes Received:
    4
    Trophy Points:
    0
    I have a screenshot on steam somewhere of all three, I'll find it and edit it in soon
    edit: it's turret+wall+ammo
    [​IMG]
     
  8. Cokemonkey11

    Cokemonkey11 Member

    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    0
    So it's a bug. Time for triage.
     
  9. Z100000M

    Z100000M Vithered Weteran

    Messages:
    9,120
    Likes Received:
    70
    Trophy Points:
    0
    fyi reproducing is a giant penis and doesnt need a cv to happen.
     
  10. Tama

    Tama Developer Staff Member Web Developer

    Messages:
    684
    Likes Received:
    74
    Trophy Points:
    0
    I wonder if getting killed while placing a wall would cause this as well. It seems like something fairly common which might explain why most often this bug is reported as being a ghost wall
     

Share This Page